summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-3.0.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index 4e90a1beb794..f41561177598 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1,3 +1,4 @@
DIST python-bugzilla-2.5.0.tar.gz 110931 BLAKE2B e7a4dc0ee00abd4bd4c55aafac8a8d2902ade116b9f35d881c3ea07441b340dc247405951b5437545720c1742f54aae3c28fe64f93191a4d7f178a3cd2db7a0e SHA512 a840db5790a7f45cdcf6ef9e261d86c6b930db30ab6340a1f351b3fd32f32e4d0f6afb68af9befef5d4e84969d568471c5c236be047f6dbab52534af3570a244
DIST python-bugzilla-3.0.0.tar.gz 112525 BLAKE2B f2746091c0152779f49502fd3394e41fdd16349c93806829a06561c49d47f6d9c9ee3b75135b9d6f66dcbb95b892aa62108634ec2e5f642b25e2cce2d06d997b SHA512 1762b1eeed125f3d35f36fa2673c1e9e808209b8723c0fdbf06f3327c40d3a5795b668913d01cf91cde3e4a0516e35c82015dbb6fc575c97b82bb421525ff03f
DIST python-bugzilla-3.0.1.tar.gz 112600 BLAKE2B b8c81b1b3f16e9b180763dcad8615c2847bf11c2a424d1fe4995091b466c202c23c072659066f66830d6d80a96a864e4148daa7a099edd2962f28345b9c9a8af SHA512 b372aa142e9e3eb456f4bba7cbc71056304ae333635c9ae85605bdcae1e5e92e13263500dba0f844c9c577bcede8ea988a753bfe23e016c8da17f3b6e9efdf3f
+DIST python-bugzilla-3.0.2.tar.gz 115324 BLAKE2B 3f64af96bf61d16e720338055391b187f53a968488535e76a5d6e56817030fc1c45f824ed27424b3e7440dc03759e77bcb8d417fa2278aa611b995bea2775f7a SHA512 c4fb79c9ca4d813a5dd9573e9a300aa01ea713fa11d43e2ee7ca13efb4720fed14fff339e9cc1b756505f43348768f0fdaaa8ae0b370640ff70e402f852e9b1a
diff --git a/dev-python/python-bugzilla/python-bugzilla-3.0.2.ebuild b/dev-python/python-bugzilla/python-bugzilla-3.0.2.ebuild
new file mode 100644
index 000000000000..24046df4f1db
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-3.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest