summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webencodings/webencodings-0.5.1-r1.ebuild30
-rw-r--r--dev-python/webencodings/webencodings-0.5.1.ebuild2
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/webencodings/webencodings-0.5.1-r1.ebuild b/dev-python/webencodings/webencodings-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..531b0c2dbcbf
--- /dev/null
+++ b/dev-python/webencodings/webencodings-0.5.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Character encoding aliases for legacy web content"
+HOMEPAGE="https://github.com/SimonSapin/python-webencodings https://pypi.org/project/webencodings/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all(){
+ cat >> setup.cfg <<- EOF
+ [tool:pytest]
+ python_files=test*.py
+ EOF
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/webencodings/webencodings-0.5.1.ebuild b/dev-python/webencodings/webencodings-0.5.1.ebuild
index 4b2dbca83027..c0ea1069cb86 100644
--- a/dev-python/webencodings/webencodings-0.5.1.ebuild
+++ b/dev-python/webencodings/webencodings-0.5.1.ebuild
@@ -23,6 +23,8 @@ DEPEND="${RDEPEND}
dev-python/pytest[${PYTHON_USEDEP}]
)"
+RESTRICT="!test? ( test )"
+
python_prepare_all(){
cat >> setup.cfg <<- EOF
[pytest]