summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qdoc/qdoc-5.12.2.ebuild')
-rw-r--r--dev-qt/qdoc/qdoc-5.12.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qdoc/qdoc-5.12.2.ebuild b/dev-qt/qdoc/qdoc-5.12.2.ebuild
new file mode 100644
index 000000000000..02aa22c368e9
--- /dev/null
+++ b/dev-qt/qdoc/qdoc-5.12.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt documentation generator"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ sys-devel/clang:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qdoc
+)
+
+src_prepare() {
+ qt_use_disable_mod qml qmldevtools-private \
+ src/qdoc/qdoc.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ # src/qdoc requires files that are only generated when qmake is
+ # run in the root directory. bug 676948; same fix as bug 633776
+ mkdir -p "${QT5_BUILD_DIR}"/src/qdoc || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ qt5-build_src_configure
+}