summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qdoc/qdoc-5.9.4.ebuild')
-rw-r--r--dev-qt/qdoc/qdoc-5.9.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-qt/qdoc/qdoc-5.9.4.ebuild b/dev-qt/qdoc/qdoc-5.9.4.ebuild
new file mode 100644
index 000000000000..983d3432a591
--- /dev/null
+++ b/dev-qt/qdoc/qdoc-5.9.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt documentation generator"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qdoc
+)
+
+src_prepare() {
+ qt_use_disable_mod qml qmldevtools-private \
+ src/qdoc/qdoc.pro
+
+ qt5-build_src_prepare
+}