summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild
new file mode 100644
index 000000000000..6f8451cd6b64
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtconcurrent-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdbus-${PV}
+ >=net-wireless/bluez-5:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtnetwork-${PV}
+"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}