summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.9.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 408a7e41e803..f459b7306dcb 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,3 +1,4 @@
DIST qtlocation-everywhere-src-5.11.0-rc2.tar.xz 5536892 BLAKE2B f3d93876ce1fd412a6c251326a22c0f9c9cccca2d3a6f4b910122ac34de5adb33a5e3deb675cd224a1694bec1935463a391cc4f8353fc692e49d0eb8fd48d37f SHA512 7e9cb0ee5e3be0e96d08ae5db92bef572e26f22200d2df463f3ee01cea5068918ded70f3769715225dfa497aff9d9de2e181f626ce044549b8a8c5b3c49ef0a1
DIST qtlocation-opensource-src-5.9.4.tar.xz 5405252 BLAKE2B 6474251b21baaac6182a0197a7736dcae86d0735e8be499c9bfefa639b3a45c750fa9bfef766849fbf6d7c5db518e5712e0862463e98168e2a3121582966d834 SHA512 a97de23a554f709a39ac8517de85c9beb7e1a8330ba3996593aeb3d64d1c5b8d8b08b0c94df435dcbb4ba5807e262ac6f87ec9620694805e0261a4b2ee8456cb
DIST qtlocation-opensource-src-5.9.5.tar.xz 5405920 BLAKE2B cd405d3a1eeed95c1c9f8759cc0d3c34d532de6f11c030296cb652e37aba66628578551fc73d5e283a373426b1e7b816b092cad1329d0a61f349650e88836a53 SHA512 80d8a8f3e82238c8a7f3e37999d5f118857e0037e60979de00219db45b3c716e6ac092f0b848c00cccbeb0ac19a1a2f4479bf92c7db701de1b3d239161d46d15
+DIST qtlocation-opensource-src-5.9.6.tar.xz 5405652 BLAKE2B 001bb5ea4d73ac67a1e1a70e3218c2cd0554b02f84001da88e3109531b8c0f51264a51276edae5c899aa68b5d1ba1bf6d55ef9e3d409b3676f60657cc8deb86c SHA512 63071f88b6b742701a0f26a11edb20e50a7a9f158c8a79dcdfd39668197963e5d505a1de828acad273ebc54f15f51fa1089ed03953cc46ca9c68ddad647ac06a
diff --git a/dev-qt/qtlocation/qtlocation-5.9.6.ebuild b/dev-qt/qtlocation/qtlocation-5.9.6.ebuild
new file mode 100644
index 000000000000..f791b5b325e3
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.9.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="The Location module for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}