summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtwidgets/qtwidgets-5.9.5.ebuild')
-rw-r--r--dev-qt/qtwidgets/qtwidgets-5.9.5.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-qt/qtwidgets/qtwidgets-5.9.5.ebuild b/dev-qt/qtwidgets/qtwidgets-5.9.5.ebuild
deleted file mode 100644
index caf1f79a84de..000000000000
--- a/dev-qt/qtwidgets/qtwidgets-5.9.5.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="Set of components for creating classic desktop-style UIs for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
-fi
-
-# keep IUSE defaults in sync with qtgui
-IUSE="gles2 gtk +png +xcb"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}[gles2=,png=,xcb?]
- gtk? (
- ~dev-qt/qtgui-${PV}[dbus]
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/pango
- )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/uic
- src/widgets
- src/plugins/platformthemes
-)
-
-QT5_GENTOO_CONFIG=(
- gtk:gtk3:
- ::widgets
- !:no-widgets:
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :widgets
-)
-
-src_configure() {
- local myconf=(
- -opengl $(usex gles2 es2 desktop)
- $(qt_use gtk)
- -gui
- $(qt_use png libpng system)
- -widgets
- $(qt_use xcb xcb system)
- $(qt_use xcb xkbcommon system)
- $(usex xcb '-xcb-xlib -xinput2 -xkb' '')
- )
- qt5-build_src_configure
-}