summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/ament_pep257/ament_pep257-9999.ebuild')
-rw-r--r--dev-ros/ament_pep257/ament_pep257-9999.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ros/ament_pep257/ament_pep257-9999.ebuild b/dev-ros/ament_pep257/ament_pep257-9999.ebuild
deleted file mode 100644
index d68cc9cf4ecc..000000000000
--- a/dev-ros/ament_pep257/ament_pep257-9999.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_7,3_8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="Checks code against style conventions in PEP 8 and generate test result files"
-HOMEPAGE="https://github.com/ament/ament_lint"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
-
-RDEPEND="
- dev-ros/ament_lint[${PYTHON_USEDEP}]
- dev-python/pydocstyle[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/ament_flake8[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-BDEPEND=""
-
-distutils_enable_tests pytest