summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/compressed_image_transport')
-rw-r--r--dev-ros/compressed_image_transport/Manifest1
-rw-r--r--dev-ros/compressed_image_transport/compressed_image_transport-1.9.2.ebuild24
-rw-r--r--dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild24
-rw-r--r--dev-ros/compressed_image_transport/metadata.xml5
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/compressed_image_transport/Manifest b/dev-ros/compressed_image_transport/Manifest
new file mode 100644
index 000000000000..431aae62326c
--- /dev/null
+++ b/dev-ros/compressed_image_transport/Manifest
@@ -0,0 +1 @@
+DIST image_transport_plugins-1.9.2.tar.gz 23734 SHA256 b610f50cdbab30abaa94980b22a444c5d898c571e3f57f0cf83ecde53877fdf0 SHA512 5ac7429cf61699f1827fdf15374aee5d951cd6aa77321f245bfe4e9771647e1bae5902646f30cb88019675e48732cd4f705eafe0931268684a449bef356bf972 WHIRLPOOL 7136449bf3fbc5f161a89c4fabac2d24fc4d4548186895e95a0aa7175ac196b5859d63da0cd59b418a570c10c767f19a8a9e7d0d408cd2c0517bff5407a512df
diff --git a/dev-ros/compressed_image_transport/compressed_image_transport-1.9.2.ebuild b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.2.ebuild
new file mode 100644
index 000000000000..f7a387a73dea
--- /dev/null
+++ b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending images encoded as JPEG or PNG"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ dev-ros/tf
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild b/dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild
new file mode 100644
index 000000000000..f7a387a73dea
--- /dev/null
+++ b/dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending images encoded as JPEG or PNG"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ dev-ros/tf
+ media-libs/opencv
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/compressed_image_transport/metadata.xml b/dev-ros/compressed_image_transport/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/compressed_image_transport/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>