summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/image_transport/image_transport-1.11.13-r1.ebuild')
-rw-r--r--dev-ros/image_transport/image_transport-1.11.13-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/image_transport/image_transport-1.11.13-r1.ebuild b/dev-ros/image_transport/image_transport-1.11.13-r1.ebuild
new file mode 100644
index 000000000000..d77bc019e972
--- /dev/null
+++ b/dev-ros/image_transport/image_transport-1.11.13-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transparent support for transporting images in low-bandwidth compressed formats"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roslib
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"