summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/pr2_msgs/pr2_msgs-1.12.3.ebuild')
-rw-r--r--dev-ros/pr2_msgs/pr2_msgs-1.12.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/pr2_msgs/pr2_msgs-1.12.3.ebuild b/dev-ros/pr2_msgs/pr2_msgs-1.12.3.ebuild
new file mode 100644
index 000000000000..5e7ff0f15b78
--- /dev/null
+++ b/dev-ros/pr2_msgs/pr2_msgs-1.12.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for representing PR2 state, such as battery information and the PR2 fingertip sensors"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"