summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild')
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild
new file mode 100644
index 000000000000..9e4951a61c85
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"