summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/robot_pose_ekf')
-rw-r--r--dev-ros/robot_pose_ekf/Manifest1
-rw-r--r--dev-ros/robot_pose_ekf/robot_pose_ekf-1.13.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/robot_pose_ekf/Manifest b/dev-ros/robot_pose_ekf/Manifest
index 2ab0c74f2366..6e83d7512541 100644
--- a/dev-ros/robot_pose_ekf/Manifest
+++ b/dev-ros/robot_pose_ekf/Manifest
@@ -1 +1,2 @@
DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
+DIST navigation-1.13.1.tar.gz 335568 SHA256 aaafdc6ee41ce79f44c03710076a105411b96dfcf35a7816607cbd0f48c8e8bc SHA512 969ce141dacc3ec8c249769a861c44a8d061bfb24c1fc63bd2873b589b11581f93e3faf3292f4db5daff89100859e05451d38278f859cb527adf55405d8f536e WHIRLPOOL f4161eb7e357384cebd2f40ead98ac559d16b055a81aee1898bfa23259d42fc88978abec195af62f4a227030b200a5a9ca79079693ebc6f3a3eb1a9d5cfb7dbb
diff --git a/dev-ros/robot_pose_ekf/robot_pose_ekf-1.13.1.ebuild b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.13.1.ebuild
new file mode 100644
index 000000000000..a2c43b164175
--- /dev/null
+++ b/dev-ros/robot_pose_ekf/robot_pose_ekf-1.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimate the 3D pose of a robot, based on (partial) pose measurements coming from different sources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ sci-libs/orocos-bfl
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ virtual/pkgconfig"