summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.8.4.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.8.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.8.4.ebuild b/dev-ros/rosapi/rosapi-0.8.4.ebuild
new file mode 100644
index 000000000000..348d9a4fa5f0
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.8.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides service calls for getting ros meta-information, like list of topics, services, params, etc."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"