summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmake/rosmake-1.13.1.ebuild')
-rw-r--r--dev-ros/rosmake/rosmake-1.13.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosmake/rosmake-1.13.1.ebuild b/dev-ros/rosmake/rosmake-1.13.1.ebuild
new file mode 100644
index 000000000000..07622ab58623
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.13.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"