summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rospack/rospack-2.4.3.ebuild')
-rw-r--r--dev-ros/rospack/rospack-2.4.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/rospack/rospack-2.4.3.ebuild b/dev-ros/rospack/rospack-2.4.3.ebuild
new file mode 100644
index 000000000000..18b9f633ad3f
--- /dev/null
+++ b/dev-ros/rospack/rospack-2.4.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ >=dev-ros/cmake_modules-0.4.1
+ test? (
+ dev-cpp/gtest
+ dev-python/nose
+ )"
+
+PATCHES=(
+ "${FILESDIR}/gentoo.patch"
+)