summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/self_test/self_test-1.9.2.ebuild')
-rw-r--r--dev-ros/self_test/self_test-1.9.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/self_test/self_test-1.9.2.ebuild b/dev-ros/self_test/self_test-1.9.2.ebuild
new file mode 100644
index 000000000000..a3bbb51a443c
--- /dev/null
+++ b/dev-ros/self_test/self_test-1.9.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot self-test node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs
+ dev-ros/diagnostic_updater
+ dev-ros/roscpp
+ dev-ros/rostest
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )"