summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rospy')
-rw-r--r--dev-ros/test_rospy/Manifest1
-rw-r--r--dev-ros/test_rospy/test_rospy-1.11.15.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/Manifest b/dev-ros/test_rospy/Manifest
index 84bda7639707..898e47a6b524 100644
--- a/dev-ros/test_rospy/Manifest
+++ b/dev-ros/test_rospy/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
+DIST ros_comm-1.11.15.tar.gz 946139 SHA256 532b8cc764e9ca8765484a4468b8537c1ddd84342896267cf3e9f6b19c1b7203 SHA512 8eea3fc948093a7640851f18856f2a20748afb80f935e28d230dc2095956d753bde5081dcd020d09638d9c5d63e031257515b6c6874286c03737507e67cce270 WHIRLPOOL 5e0a971f4312dce99c2e2c11841445cea999dbe5b1ebde3ce26badb9a7eaf9fb84220ed5d1e0088e85835104ddad3cd4d555708d010f83da6e84d257bafe699b
diff --git a/dev-ros/test_rospy/test_rospy-1.11.15.ebuild b/dev-ros/test_rospy/test_rospy-1.11.15.ebuild
new file mode 100644
index 000000000000..174ea68dbec0
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.11.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"