summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf2_ros/tf2_ros-9999.ebuild')
-rw-r--r--dev-ros/tf2_ros/tf2_ros-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-ros/tf2_ros/tf2_ros-9999.ebuild b/dev-ros/tf2_ros/tf2_ros-9999.ebuild
index 00234a1ad22c..0cecd8403f76 100644
--- a/dev-ros/tf2_ros/tf2_ros-9999.ebuild
+++ b/dev-ros/tf2_ros/tf2_ros-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/geometry2"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -24,8 +23,11 @@ RDEPEND="
dev-ros/tf2
dev-ros/tf2_py[${PYTHON_USEDEP}]
dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"