summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf2_ros')
-rw-r--r--dev-ros/tf2_ros/Manifest1
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.7.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/Manifest b/dev-ros/tf2_ros/Manifest
index e386e7e8eadf..4e3cdf274309 100644
--- a/dev-ros/tf2_ros/Manifest
+++ b/dev-ros/tf2_ros/Manifest
@@ -1 +1,2 @@
DIST geometry2-0.7.2.tar.gz 174319 BLAKE2B 0f319055cf0a4c8a425c31abc981ee1aee3c77b9dae8e0ddae6a0c4bdf09c31373b8005cb05177374ae5a2139c0f49a4cfdd5b966f8e991827ca2c6e471dcdd2 SHA512 8c2ad4e67d4d7509c3d9a7ef781d454eeb570fbc29d201ece7d2613258b7bed2ba00398655901e2b5856b59acad94422dbb6ae1f0bd545b3a41353204c31d00b
+DIST geometry2-0.7.3.tar.gz 175974 BLAKE2B a0edbeea6db30f07d5cf6ddd4d0a8a1ce0221c8b0ad01929aa6a73a7a49e2e5bd08dfd01cef6cd964ea93b6e8f5aa1dd6ec395e8e4bbafa1117eb3436cae9c10 SHA512 20d207218000905a17411ee9c662778b3022481e84b903ca616cdfc439b2af55c7182988dc843103edc471d564e988fa311be916d0810ec86228585500ed532e
diff --git a/dev-ros/tf2_ros/tf2_ros-0.7.3.ebuild b/dev-ros/tf2_ros/tf2_ros-0.7.3.ebuild
new file mode 100644
index 000000000000..09a9bc9fc7c8
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.7.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ )
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+
+src_test() {
+ # Needed for tests to find internal launch file
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}