summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/urdf/urdf-1.13.1.ebuild')
-rw-r--r--dev-ros/urdf/urdf-1.13.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/urdf/urdf-1.13.1.ebuild b/dev-ros/urdf/urdf-1.13.1.ebuild
new file mode 100644
index 000000000000..ab97666057c9
--- /dev/null
+++ b/dev-ros/urdf/urdf-1.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/urdf"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="C++ parser for the Unified Robot Description Format (URDF)"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-libs/urdfdom
+ dev-libs/urdfdom_headers
+ dev-ros/urdf_parser_plugin
+ dev-ros/pluginlib
+ dev-ros/rosconsole_bridge
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-libs/tinyxml
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-cpp/gtest )"