summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/urg_node/urg_node-9999.ebuild')
-rw-r--r--dev-ros/urg_node/urg_node-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/urg_node/urg_node-9999.ebuild b/dev-ros/urg_node/urg_node-9999.ebuild
new file mode 100644
index 000000000000..e70e01112a0d
--- /dev/null
+++ b/dev-ros/urg_node/urg_node-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/urg_node"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for the Hokuyo urg_c library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/urg_c
+ dev-ros/tf
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nodelet
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/diagnostic_updater
+ dev-ros/laser_proc
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"