summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/xacro/xacro-1.11.1.ebuild')
-rw-r--r--dev-ros/xacro/xacro-1.11.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/xacro/xacro-1.11.1.ebuild b/dev-ros/xacro/xacro-1.11.1.ebuild
new file mode 100644
index 000000000000..b80386dd62c4
--- /dev/null
+++ b/dev-ros/xacro/xacro-1.11.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/xacro"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="XML macro language"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roslint[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+RDEPEND="${RDEPEND}
+ dev-ros/roslaunch[${PYTHON_USEDEP}]"