summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/xmlrpcpp/xmlrpcpp-1.15.8-r1.ebuild')
-rw-r--r--dev-ros/xmlrpcpp/xmlrpcpp-1.15.8-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/xmlrpcpp/xmlrpcpp-1.15.8-r1.ebuild b/dev-ros/xmlrpcpp/xmlrpcpp-1.15.8-r1.ebuild
new file mode 100644
index 000000000000..f3fb15501966
--- /dev/null
+++ b/dev-ros/xmlrpcpp/xmlrpcpp-1.15.8-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++ implementation of the XML-RPC protocol"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-cpp/gtest
+ dev-libs/boost[threads(+)]
+ )
+"