summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/nav_core/Manifest1
-rw-r--r--dev-ros/nav_core/nav_core-1.17.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/nav_core/Manifest b/dev-ros/nav_core/Manifest
index a4fee98c8c5a..494e2eda7805 100644
--- a/dev-ros/nav_core/Manifest
+++ b/dev-ros/nav_core/Manifest
@@ -1 +1,2 @@
DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
+DIST navigation-1.17.1.tar.gz 349192 BLAKE2B 4cb946a296ab53d7196a70c66cc1dda0cf62f5f279fe020ca7c39781ecb5402af6addcd6164ab6e0a9bcfe3ba26e42f647546280f03b572202f0f4df8d6ed3cf SHA512 23178adaef9b720c644f621c67ed579be312101e70a7d12b527164c5cc55286982c99149a521a76c6dda05248e859435e51f9a0f09e582b89aed3b7c2173cfaa
diff --git a/dev-ros/nav_core/nav_core-1.17.1.ebuild b/dev-ros/nav_core/nav_core-1.17.1.ebuild
new file mode 100644
index 000000000000..389fbe3ca74a
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-1.17.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+"
+DEPEND="${RDEPEND}"