summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/combined_robot_hw/Manifest1
-rw-r--r--dev-ros/combined_robot_hw/combined_robot_hw-0.11.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/combined_robot_hw/Manifest b/dev-ros/combined_robot_hw/Manifest
index 7e38aa6703d3..1fe365b0c095 100644
--- a/dev-ros/combined_robot_hw/Manifest
+++ b/dev-ros/combined_robot_hw/Manifest
@@ -1 +1,2 @@
DIST ros_control-0.11.0.tar.gz 633993 SHA256 a21839b729459f752f9a37b73965e116dfbd36c6e9edc4e85a9791cdf469f16c SHA512 fe18a513c12db60a4e49a37ec9588a448e24acd618162930dd6772a2bdc9855d56e56a45d0ba4f2e2c1ce29551efb93e3db0f2232a1ddf4ca40c053cf5845fd5 WHIRLPOOL 47dfe7fd5b01fc47a5aa38a6389a046af92363ddc26226900d347aa44e0f3d56da585e7acd87a7256c2d472769976e51aceb052241afdbbf9e8ee7c4b485e665
+DIST ros_control-0.11.1.tar.gz 634118 SHA256 72cf017ce1de3a645e62c7f1c034c4acaa2d3bc1d81da73b9c3b6027f89a48e8 SHA512 2ac330025e0740637a3143e6a783d5fdaf33567314a48b50a736e9fbc032b2ea153d002b5a2e1aad8fe2e88ddc9b61f6f5bcbecbf63471cf325c3acdf0dd999f WHIRLPOOL 200717b61336c9fdf9aa9ac640789dbdd68f7da4b90c49390e95fe2dee4731bebea549ce3343a714c6593c097fee08e531a01a0b4b909aba1cb742860c5b80d5
diff --git a/dev-ros/combined_robot_hw/combined_robot_hw-0.11.1.ebuild b/dev-ros/combined_robot_hw/combined_robot_hw-0.11.1.ebuild
new file mode 100644
index 000000000000..16b864938ed2
--- /dev/null
+++ b/dev-ros/combined_robot_hw/combined_robot_hw-0.11.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/ros_control"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Combined Robot HW class"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/hardware_interface-0.11
+ dev-ros/pluginlib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"