summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/robot_localization/Manifest1
-rw-r--r--dev-ros/robot_localization/files/nowerror.patch13
-rw-r--r--dev-ros/robot_localization/robot_localization-2.6.2.ebuild45
-rw-r--r--dev-ros/robot_localization/robot_localization-9999.ebuild4
4 files changed, 62 insertions, 1 deletions
diff --git a/dev-ros/robot_localization/Manifest b/dev-ros/robot_localization/Manifest
index 1ac5083c6f4a..58e2de03ea8d 100644
--- a/dev-ros/robot_localization/Manifest
+++ b/dev-ros/robot_localization/Manifest
@@ -1 +1,2 @@
DIST robot_localization-2.5.2.tar.gz 6467525 BLAKE2B 68e1eab37c0856f73ef4ef3a1d7c6fb5f7771c98d8a84fad417173c41f8ddb876221d5eb2846bc9965c831fb64b215829d418b315e164f9e39e20ceec6b9da2c SHA512 b5cbc628c5a0fe9684d86d461ab25f494d693fbcbc9ac47ddcf7eb26d61512c078f8fa0747e929c1ae4e2d451770196ff767058036af9246b7e43cc537797e6f
+DIST robot_localization-2.6.2.tar.gz 6468164 BLAKE2B 75d8d8d0ff659868fa3f3d4469381ebcc196b0601e3fcf03739173d8335e9bb7c71418455285f85b8e31748363e8a0b10100d69b74035fe08dd4d138831a9472 SHA512 d8b111a644765fc1301bb8c46437bdd0a05acf76e4ee9e6ded7e4b8ec833020ed70a084697d2bb99a7c0e518f2b690a5e9c79a34f4acf717729fdd0c0fdf1c1a
diff --git a/dev-ros/robot_localization/files/nowerror.patch b/dev-ros/robot_localization/files/nowerror.patch
new file mode 100644
index 000000000000..936ad259bc6f
--- /dev/null
+++ b/dev-ros/robot_localization/files/nowerror.patch
@@ -0,0 +1,13 @@
+Index: robot_localization-2.6.2/CMakeLists.txt
+===================================================================
+--- robot_localization-2.6.2.orig/CMakeLists.txt
++++ robot_localization-2.6.2/CMakeLists.txt
+@@ -36,7 +36,7 @@ if(NOT EIGEN3_FOUND)
+ set(EIGEN_PACKAGE Eigen)
+ endif()
+
+-set_directory_properties(PROPERTIES COMPILE_OPTIONS "-std=c++14;-Wall;-Werror")
++set_directory_properties(PROPERTIES COMPILE_OPTIONS "-std=c++14;-Wall")
+ add_definitions(-DEIGEN_NO_DEBUG -DEIGEN_MPL2_ONLY)
+
+ set(ROSLINT_CPP_OPTS "--filter=-build/c++11,-runtime/references")
diff --git a/dev-ros/robot_localization/robot_localization-2.6.2.ebuild b/dev-ros/robot_localization/robot_localization-2.6.2.ebuild
new file mode 100644
index 000000000000..f94e26c36120
--- /dev/null
+++ b/dev-ros/robot_localization/robot_localization-2.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/cra-ros-pkg/robot_localization"
+KEYWORDS="~amd64"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geographic_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Package of nonlinear state estimation nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_updater
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/eigen_conversions
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ dev-cpp/yaml-cpp:=
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/roslint
+ dev-cpp/eigen:3
+ test? ( dev-ros/rosbag dev-ros/rostest dev-ros/rosunit )
+"
+
+PATCHES=( "${FILESDIR}/nowerror.patch" )
diff --git a/dev-ros/robot_localization/robot_localization-9999.ebuild b/dev-ros/robot_localization/robot_localization-9999.ebuild
index 939215f937b7..f94e26c36120 100644
--- a/dev-ros/robot_localization/robot_localization-9999.ebuild
+++ b/dev-ros/robot_localization/robot_localization-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -41,3 +41,5 @@ DEPEND="${RDEPEND}
dev-cpp/eigen:3
test? ( dev-ros/rosbag dev-ros/rostest dev-ros/rosunit )
"
+
+PATCHES=( "${FILESDIR}/nowerror.patch" )