summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/tf2_ros/Manifest1
-rw-r--r--dev-ros/tf2_ros/tf2_ros-0.5.13.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/tf2_ros/Manifest b/dev-ros/tf2_ros/Manifest
index ec008bbcd231..e6ba39e1c4eb 100644
--- a/dev-ros/tf2_ros/Manifest
+++ b/dev-ros/tf2_ros/Manifest
@@ -1 +1,2 @@
DIST geometry_experimental-0.5.12.tar.gz 131234 SHA256 430115ef4a3352e8b00596ff7406e6cb14fc1720250cf164754cf724c7f371c3 SHA512 1a1a33db529d0810661c020552642d914de01a14e5b17b611fb7743a795c47e3f68d480ee4544b4ad86f7b1c947ea8b23cda09535ce046fdc45da1c40fc34711 WHIRLPOOL fd894a43e0110eeab1f085faa32a339a72d922d57ae68ee82c2b54f73c246090f3537483f1ca68147f5b7b7a5c7502f9fd4ab733da150c68af94ea2d87859ab1
+DIST geometry_experimental-0.5.13.tar.gz 134107 SHA256 20ad7d3b610c70e8c666937d6a29ef53dac9181025427ee6d0664c67ff94b43f SHA512 5b31a2ec2c8f852934c1c9a6aa0127c96b8f334f178742111c673195562a240649ac11ddde8d9738defae99184bdd83a57430fe6f17eb4cbd08ae600bfa7d43d WHIRLPOOL 06da030383725aaeda8626f36b56911cc05c025b538904f33cdc69975027f610113945a3479d85fe83df841fcb1f4902b8927cae2a2272e44f59b86c97d844fc
diff --git a/dev-ros/tf2_ros/tf2_ros-0.5.13.ebuild b/dev-ros/tf2_ros/tf2_ros-0.5.13.ebuild
new file mode 100644
index 000000000000..248dddf79d08
--- /dev/null
+++ b/dev-ros/tf2_ros/tf2_ros-0.5.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry_experimental"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS bindings for the tf2 library, for both Python and C++"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/rosgraph
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"