summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actiontext/actiontext-6.0.1.ebuild')
-rw-r--r--dev-ruby/actiontext/actiontext-6.0.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-ruby/actiontext/actiontext-6.0.1.ebuild b/dev-ruby/actiontext/actiontext-6.0.1.ebuild
deleted file mode 100644
index 2caeb0640662..000000000000
--- a/dev-ruby/actiontext/actiontext-6.0.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Edit and display rich text in Rails applications"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/actionpack-${PV}
- ~dev-ruby/activerecord-${PV}
- ~dev-ruby/activestorage-${PV}
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/nokogiri-1.8.5
-"
-
-ruby_add_bdepend "test? (
- dev-ruby/mocha
-)"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
- rm ../Gemfile.lock || die
-}
-
-each_ruby_prepare() {
- sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
-}