summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/amqp/amqp-1.8.0-r1.ebuild')
-rw-r--r--dev-ruby/amqp/amqp-1.8.0-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-ruby/amqp/amqp-1.8.0-r1.ebuild b/dev-ruby/amqp/amqp-1.8.0-r1.ebuild
deleted file mode 100644
index 8dd9260cbc0a..000000000000
--- a/dev-ruby/amqp/amqp-1.8.0-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="AMQP client implementation in Ruby/EventMachine"
-HOMEPAGE="http://rubyamqp.info/"
-
-LICENSE="Ruby"
-SLOT="1.4"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/multi_json dev-ruby/evented-spec )"
-ruby_add_rdepend ">=dev-ruby/eventmachine-0.12.4
- >=dev-ruby/amq-protocol-2.2.0:2"
-
-all_ruby_prepare() {
- #rm Gemfile || die
- sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
-
- # Many specs require a live rabbit server, but only root can start
- # an instance. Skip these specs for now.
- rm -rf spec/integration spec/unit/amqp/connection_spec.rb || die
-}
-
-all_ruby_install() {
- dodoc -r docs examples
-}