summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ast/ast-2.3.0.ebuild')
-rw-r--r--dev-ruby/ast/ast-2.3.0.ebuild31
1 files changed, 0 insertions, 31 deletions
diff --git a/dev-ruby/ast/ast-2.3.0.ebuild b/dev-ruby/ast/ast-2.3.0.ebuild
deleted file mode 100644
index 699c86637039..000000000000
--- a/dev-ruby/ast/ast-2.3.0.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A library for working with abstract syntax trees"
-HOMEPAGE="https://github.com/whitequark/ast"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/bacon )"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e "/git ls/d" ${PN}.gemspec || die
- sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S bacon -Itest -a || die
-}