summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bundler/bundler-2.2.6.ebuild')
-rw-r--r--dev-ruby/bundler/bundler-2.2.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bundler/bundler-2.2.6.ebuild b/dev-ruby/bundler/bundler-2.2.6.ebuild
new file mode 100644
index 000000000000..8256c6960865
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git !<dev-ruby/bundler-1.17.3-r1:0"