summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/colored2/colored2-3.1.2.ebuild')
-rw-r--r--dev-ruby/colored2/colored2-3.1.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/colored2/colored2-3.1.2.ebuild b/dev-ruby/colored2/colored2-3.1.2.ebuild
new file mode 100644
index 000000000000..5a158dea39ff
--- /dev/null
+++ b/dev-ruby/colored2/colored2-3.1.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Console coloring"
+HOMEPAGE="https://github.com/kigster/colored2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}