summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/equatable/equatable-0.7.0.ebuild')
-rw-r--r--dev-ruby/equatable/equatable-0.7.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/equatable/equatable-0.7.0.ebuild b/dev-ruby/equatable/equatable-0.7.0.ebuild
new file mode 100644
index 000000000000..fe460e5d01a7
--- /dev/null
+++ b/dev-ruby/equatable/equatable-0.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="equatable.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows ruby objects to implement equality comparison and inspection methods"
+HOMEPAGE="https://github.com/piotrmurach/equatable"
+SRC_URI="https://github.com/piotrmurach/equatable/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}