summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/faker/faker-2.19.0.ebuild')
-rw-r--r--dev-ruby/faker/faker-2.19.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/faker/faker-2.19.0.ebuild b/dev-ruby/faker/faker-2.19.0.ebuild
new file mode 100644
index 000000000000..82e8579cf790
--- /dev/null
+++ b/dev-ruby/faker/faker-2.19.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+RUBY_FAKEGEM_GEMSPEC="faker.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for generating fake data such as names, addresses, and phone numbers"
+HOMEPAGE="https://github.com/stympy/faker"
+SRC_URI="https://github.com/stympy/faker/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/i18n-1.6:1 !!<dev-ruby/faker-1.9.6-r1"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|rubocop\|yard\)/I s:^:#:' Rakefile || die
+ sed -i -e '/simplecov/,/^end/ s:^:#:' test/test_helper.rb || die
+}