summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/gherkin/gherkin-4.1.2.ebuild')
-rw-r--r--dev-ruby/gherkin/gherkin-4.1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/gherkin/gherkin-4.1.2.ebuild b/dev-ruby/gherkin/gherkin-4.1.2.ebuild
new file mode 100644
index 000000000000..69941e0dcded
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-4.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+# Don't install support scripts to avoid slot collisions.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser"
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE=""