summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/Manifest1
-rw-r--r--dev-ruby/kramdown/kramdown-1.16.2.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-ruby/kramdown/Manifest b/dev-ruby/kramdown/Manifest
index b2b4c3469a14..b6f42f560b9b 100644
--- a/dev-ruby/kramdown/Manifest
+++ b/dev-ruby/kramdown/Manifest
@@ -1,2 +1 @@
-DIST kramdown-1.16.2.gem 258048 BLAKE2B a9b35b9e3882cafa32721d0555fa10d806973d4f6e7b617395c00acd3aee43552d74be2442411dc04fec48f7878a7459621ee7848365c165b51959e03a9451da SHA512 da6981969aca283c50b5a34650833c1364afcf74ecc64daba1eed20b198490bf1fdda91096f37574281b50f36713326c367307137446b1fd84a049358a13e4d7
DIST kramdown-1.17.0.gem 260608 BLAKE2B 56f0abb2c94ab2de31bcd71940c22610efc8143c434295627513735b5983a369b0d9b36a88477a4e0b14bb23a3d314280702655c854cb7134e29bebc1f276966 SHA512 0f98f4234dec41b53d7f116be1075176c7fcbf21621c6f52a9e5b4055a777b01f1a0a912be81a651e85df022e7bab3ac183ee66cd87abeae092cd1920aceff04
diff --git a/dev-ruby/kramdown/kramdown-1.16.2.ebuild b/dev-ruby/kramdown/kramdown-1.16.2.ebuild
deleted file mode 100644
index 6a4539198e65..000000000000
--- a/dev-ruby/kramdown/kramdown-1.16.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using strict syntax definition"
-HOMEPAGE="https://kramdown.gettalong.org/"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
-IUSE="latex"
-
-LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
-RDEPEND+=" ${LATEX_DEPS}"
-DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
-
-ruby_add_rdepend "dev-ruby/prawn:2
- >=dev-ruby/prawn-table-0.2.2 =dev-ruby/prawn-table-0.2*
- >=dev-ruby/rouge-1.8:*
- >=dev-ruby/itextomml-1.5
- >=dev-ruby/coderay-1.0.0
- >=dev-ruby/ritex-1.0
- >=dev-ruby/stringex-1.5.1"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )
- test? ( >=dev-ruby/minitest-5.0 )"
-
-all_ruby_prepare() {
- if ! use latex; then
- # Remove latex tests. They will fail gracefully when latex isn't
- # present at all, but not when components are missing (most
- # notable ucs.sty).
- sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
- fi
-
- # Avoid tests requiring node to be installed with mathjaxnode.
- rm -f test/testcases/span/math/mathjaxnode* \
- test/testcases/block/15_math/mathjaxnode* || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- doman man/man1/kramdown.1
-}