summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/listen/listen-1.3.1-r4.ebuild')
-rw-r--r--dev-ruby/listen/listen-1.3.1-r4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/listen/listen-1.3.1-r4.ebuild b/dev-ruby/listen/listen-1.3.1-r4.ebuild
new file mode 100644
index 000000000000..a7eb38fa908e
--- /dev/null
+++ b/dev-ruby/listen/listen-1.3.1-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Listens to file modifications and notifies you about the changes"
+HOMEPAGE="https://github.com/guard/listen"
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~ppc64 ~amd64-linux ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+ # Drop failing test
+ sed -i -e '/#85/,+17d' spec/listen/directory_record_spec.rb || die
+
+ # Drop dependencies for file system events not available on Gentoo.
+ sed -i -e '/\(fsevent\|kqueue\)/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}