summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/loofah')
-rw-r--r--dev-ruby/loofah/Manifest4
-rw-r--r--dev-ruby/loofah/loofah-2.22.0.ebuild (renamed from dev-ruby/loofah/loofah-2.19.1.ebuild)6
-rw-r--r--dev-ruby/loofah/loofah-2.23.0.ebuild39
-rw-r--r--dev-ruby/loofah/loofah-2.23.1.ebuild39
4 files changed, 84 insertions, 4 deletions
diff --git a/dev-ruby/loofah/Manifest b/dev-ruby/loofah/Manifest
index 271dac38bb9d..e47fe2f2032c 100644
--- a/dev-ruby/loofah/Manifest
+++ b/dev-ruby/loofah/Manifest
@@ -1 +1,3 @@
-DIST loofah-2.19.1.tar.gz 81858 BLAKE2B e4383f9b867d9cbd04e8c8ea3cb23d89c56513690fd93eda31cb2e36659dc8ad0d8035f97d8a505cd9beb248db6f3bd3dd775b87a1995e8e6f553fbcb20970c9 SHA512 0bca5523824842bfc8b92b349bd21c0c8f8a1fb70a035e199e86920f21cd732adf58c7fd385212cad5bddf08c56b0141a692218feae2369c510c278fd824cb03
+DIST loofah-2.22.0.tar.gz 85892 BLAKE2B d465dcc83cac2a994145f7840b8607f92a080fef7ef6860ae81a3eecaf41be6be7e3b59263c05d09c5a729844d4f2490ce3e39046fdd863647ac157367c16427 SHA512 b1b9ba490334563b935d8a176ba6eee8d98c5c3ebbecc878c654e64a48311c38d0684a9b8e2704797c36492a33bc1248137a7611eb9f796a5ea9aa4df1b5f90e
+DIST loofah-2.23.0.tar.gz 86416 BLAKE2B 58344fbd9b3c94fa739ae29ba595be81e8617c987054ac8990aab4dd5caf8b2edb2b81f0f4745a08f305b83413e9c5e45dc953f97f1018383b5f1b203bf25df3 SHA512 7dd8eff48a4574b41ecadadba1730c0225e2a99590a83f1c5faaf2b62697e910533e24f96e873a9c96da4eece02cadc08a0004dbff177e23a9e66d900271f3f0
+DIST loofah-2.23.1.tar.gz 86486 BLAKE2B 7fcc58b3ee7ca082a6be89f7e10a475d2e17a5ad2837d5ead7574dc99bfa1e2b49660715a3137a422fde8bcab5208b8d6445214ec98a5b3fa2f0c149e25c0cb8 SHA512 1251fb69aa815306c01e864745074276280e1402a3540ed94f927d49231911baa56a113ab69c3cb24ee52c094b33d2cd2a63e36482dce517d169affa63673fbc
diff --git a/dev-ruby/loofah/loofah-2.19.1.ebuild b/dev-ruby/loofah/loofah-2.22.0.ebuild
index 0ba6264f247f..837891432690 100644
--- a/dev-ruby/loofah/loofah-2.19.1.ebuild
+++ b/dev-ruby/loofah/loofah-2.22.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
IUSE=""
-ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.5.9"
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.12.0"
ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 )"
diff --git a/dev-ruby/loofah/loofah-2.23.0.ebuild b/dev-ruby/loofah/loofah-2.23.0.ebuild
new file mode 100644
index 000000000000..a0a8d2e8bf18
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.23.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="loofah.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+SRC_URI="https://github.com/flavorjones/loofah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.12.0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 )"
+
+all_ruby_prepare() {
+ # Fix version in gemspec
+ sed -i -e '/s\.version/ s/".*"/"'${PV}'"/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid unneeded development dependencies
+ sed -i -e '/concourse/I s:^:#:' Rakefile || die
+
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/loofah/loofah-2.23.1.ebuild b/dev-ruby/loofah/loofah-2.23.1.ebuild
new file mode 100644
index 000000000000..a0a8d2e8bf18
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.23.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="loofah.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+SRC_URI="https://github.com/flavorjones/loofah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.12.0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 )"
+
+all_ruby_prepare() {
+ # Fix version in gemspec
+ sed -i -e '/s\.version/ s/".*"/"'${PV}'"/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid unneeded development dependencies
+ sed -i -e '/concourse/I s:^:#:' Rakefile || die
+
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}