summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/loquacious')
-rw-r--r--dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild b/dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild
new file mode 100644
index 000000000000..63f45cc4568d
--- /dev/null
+++ b/dev-ruby/loquacious/loquacious-1.9.1-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
+HOMEPAGE="https://github.com/TwP/loquacious"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ sed -i -e 's/be_true/be true/' -e 's/be_false/be false/' spec/*_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}