summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/marcel/marcel-1.0.2.ebuild')
-rw-r--r--dev-ruby/marcel/marcel-1.0.2.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-ruby/marcel/marcel-1.0.2.ebuild b/dev-ruby/marcel/marcel-1.0.2.ebuild
index f6bada748471..19ad146b8b8e 100644
--- a/dev-ruby/marcel/marcel-1.0.2.ebuild
+++ b/dev-ruby/marcel/marcel-1.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -11,8 +11,8 @@ RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
inherit ruby-fakegem
DESCRIPTION="Simple mime type detection using magic numbers, filenames, and extensions"
-HOMEPAGE="https://github.com/basecamp/marcel"
-SRC_URI="https://github.com/basecamp/marcel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/rails/marcel"
+SRC_URI="https://github.com/rails/marcel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0 MIT"
SLOT="$(ver_cut 1-2)"
@@ -29,4 +29,6 @@ all_ruby_prepare() {
test/test_helper.rb || die
sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ sed -i -e 's/MiniTest/Minitest/' test/test_helper.rb || die
}