summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minitest-around')
-rw-r--r--dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
index a728f0955a6e..c1444d3859dc 100644
--- a/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
+++ b/dev-ruby/minitest-around/minitest-around-0.5.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -14,8 +14,8 @@ HOMEPAGE="https://github.com/splattael/minitest-around"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 arm arm64 ~hppa ~ppc ~ppc64 ~riscv x86"
-IUSE=""
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
+IUSE="test"
ruby_add_rdepend "dev-ruby/minitest:5"
@@ -25,6 +25,8 @@ all_ruby_prepare() {
sed -i -e '/bump/ s:^:#:' \
-e '/ls-files/d' \
-e '/cucumber/ s/,.*$//' minitest-around.gemspec Rakefile || die
+ sed -e '/bundler/ s:^:#:' \
+ -i test/helper.rb Rakefile || die
}
each_ruby_test() {