summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/minitest-hooks')
-rw-r--r--dev-ruby/minitest-hooks/Manifest1
-rw-r--r--dev-ruby/minitest-hooks/metadata.xml11
-rw-r--r--dev-ruby/minitest-hooks/minitest-hooks-1.4.0.ebuild20
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/minitest-hooks/Manifest b/dev-ruby/minitest-hooks/Manifest
new file mode 100644
index 000000000000..80516afaa201
--- /dev/null
+++ b/dev-ruby/minitest-hooks/Manifest
@@ -0,0 +1 @@
+DIST minitest-hooks-1.4.0.gem 10240 SHA256 1f95946599b91da45ee83d93a35309ee8355028383e3828a1a3b010660f54e24 SHA512 ad89173076cf8af9f198719bb5fd2ac3524f1aa9a98c4010e091056e3a195eaead59a0b2cb7361441f4b376b1823fac55fb077903d04034c31a426372ee28f30 WHIRLPOOL 88d215f1155f9580e09f4c086e739089d421171b94c93d9608b527ced50f6fab20fee6be2a617125d52c7088eaa564422db6513ef0094204456bce458e9bb6c3
diff --git a/dev-ruby/minitest-hooks/metadata.xml b/dev-ruby/minitest-hooks/metadata.xml
new file mode 100644
index 000000000000..5f00328f3ad8
--- /dev/null
+++ b/dev-ruby/minitest-hooks/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jeremyevans/minitest-hooks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/minitest-hooks/minitest-hooks-1.4.0.ebuild b/dev-ruby/minitest-hooks/minitest-hooks-1.4.0.ebuild
new file mode 100644
index 000000000000..c6d03d943224
--- /dev/null
+++ b/dev-ruby/minitest-hooks/minitest-hooks-1.4.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+# Skip tests since they require unpackaged sequel
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds around and before_all/after_all/around_all hooks for Minitest"
+HOMEPAGE="https://github.com/jeremyevans/minitest-hooks"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""