summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/net-ssh/net-ssh-3.1.1.ebuild')
-rw-r--r--dev-ruby/net-ssh/net-ssh-3.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/net-ssh/net-ssh-3.1.1.ebuild b/dev-ruby/net-ssh/net-ssh-3.1.1.ebuild
new file mode 100644
index 000000000000..89977477eb77
--- /dev/null
+++ b/dev-ruby/net-ssh/net-ssh-3.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.txt README.rdoc THANKS.txt"
+RUBY_FAKEGEM_EXTRAINSTALL="support"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Non-interactive SSH processing in pure Ruby"
+HOMEPAGE="https://github.com/net-ssh/net-ssh"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> net-ssh-git-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 >=dev-ruby/mocha-0.13 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_all.rb || die "Tests failed."
+}