summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/oauth-0.5.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.4.ebuild b/dev-ruby/oauth/oauth-0.5.4.ebuild
index 1b883606f567..fd90e9faa800 100644
--- a/dev-ruby/oauth/oauth-0.5.4.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
+USE_RUBY="ruby23 ruby24 ruby25"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -25,12 +25,12 @@ ruby_add_bdepend "test? (
dev-ruby/mocha:1.0
dev-ruby/webmock
dev-ruby/rack
- dev-ruby/actionpack:5.1
+ dev-ruby/actionpack:5.2
)"
all_ruby_prepare() {
# Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.1.0"' \
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "actionpack", "~>5.2.0"' \
-e '2i gem "test-unit"; require "test/unit"' \
-e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
}