summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/omniauth')
-rw-r--r--dev-ruby/omniauth/Manifest1
-rw-r--r--dev-ruby/omniauth/omniauth-2.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
index a105ed73fd6c..a7597c449f36 100644
--- a/dev-ruby/omniauth/Manifest
+++ b/dev-ruby/omniauth/Manifest
@@ -1 +1,2 @@
DIST omniauth-2.0.4.tar.gz 30951 BLAKE2B 6086a737e043ae37e6c7c4b1e4d597a08e6dc490c5d71f7847e9c5a8880bbbd1117470efbbe12e150bf238bf6e5413493712f1c09ae5e37f5d7b7676b6da023e SHA512 c92ce881388c9793e96354caee764cbabb28c69ca63b32f304693c4859eb8bf994e86b2cc9dbeb57993347e6f2787c43eab967c36730d5c47a3c4767d16847eb
+DIST omniauth-2.1.0.tar.gz 31135 BLAKE2B b221c084b926e3ac9e31858268940d0bd8583c667c7bcb8ce14e7fbda91c06c286191ffeff36c17d1d668ee29ca850b377312f2f2a417c47cb1dd4e8a447a641 SHA512 f1dde6f527b6aafdbed83ce6e14dae39617b738c6e80e9ece3d768ef9f63a87924ef2ef92b99ecc52bd69c0103854f16ff9c80f3d2eeb7c134fc70ab0157df63
diff --git a/dev-ruby/omniauth/omniauth-2.1.0.ebuild b/dev-ruby/omniauth/omniauth-2.1.0.ebuild
new file mode 100644
index 000000000000..16d0da9a9ceb
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/rack-2.2.3
+ dev-ruby/rack-protection
+ >=dev-ruby/hashie-3.4.6:*"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/RUBY_VERSION/,/^end/ s:^:#: ; /freeze/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}