summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/open4/open4-1.3.4.ebuild')
-rw-r--r--dev-ruby/open4/open4-1.3.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/open4/open4-1.3.4.ebuild b/dev-ruby/open4/open4-1.3.4.ebuild
new file mode 100644
index 000000000000..5ef01faa37d8
--- /dev/null
+++ b/dev-ruby/open4/open4-1.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Open3::popen3 with exit status"
+HOMEPAGE="https://github.com/ahoward/open4"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ mv rakefile Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}/samples
+ doins samples/*
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -Itest/lib test/*.rb || die
+}