summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/power_assert/power_assert-1.2.0.ebuild')
-rw-r--r--dev-ruby/power_assert/power_assert-1.2.0.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/power_assert/power_assert-1.2.0.ebuild b/dev-ruby/power_assert/power_assert-1.2.0.ebuild
deleted file mode 100644
index 18a85b535c72..000000000000
--- a/dev-ruby/power_assert/power_assert-1.2.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="power_assert.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Shows each value of variables and method calls in the expression"
-HOMEPAGE="https://github.com/ruby/power_assert"
-SRC_URI="https://github.com/ruby/power_assert/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( Ruby BSD-2 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-SLOT="0"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit )"
-
-all_ruby_prepare() {
- sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
- sed -i -e '1igem "test-unit"' \
- -e '/byebug/ s:^:#:' test/test_helper.rb || die
-
- # Avoid git dependency
- sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid circular dependency on byebug when bootstrapping ruby
- sed -i -e '/byebug/ s:^:#:' -e '/test_core_ext_helper/ s:^:#:' test/test_helper.rb || die
- rm test/test_core_ext_helper.rb test/trace_test.rb || die
-
- # Avoid circular dependency on pry when bootstrapping ruby
- sed -i -e '/pry/ s:^:#:' -e '/test_colorized_pp/,/^ end/ s:^:#:' test/block_test.rb || die
-}