summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pry')
-rw-r--r--dev-ruby/pry/Manifest1
-rw-r--r--dev-ruby/pry/pry-0.12.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/pry/Manifest b/dev-ruby/pry/Manifest
index d012005f563f..7cb0ec589ba7 100644
--- a/dev-ruby/pry/Manifest
+++ b/dev-ruby/pry/Manifest
@@ -1 +1,2 @@
DIST pry-0.11.3.tar.gz 225483 BLAKE2B a8d680c095a887e2612b61ef2f892ece8468e447f08e209b97494844fb27cf2441b8d575125ac5657b6f0feefa8b2726bfd78966ce44da1d96af84982918f428 SHA512 6c5c983d0d446cc7cf105797083d932d95db9821215635cd3929ce2e229e21c4566d0644a6283de462e735aef577cd8c115589d2dd8bac88ac2f911be0bf729f
+DIST pry-0.12.0.tar.gz 237643 BLAKE2B 3c1d749c4df638652d0c9e2a11efe1c48225f2aa434e1adb3323fa5cc21fce40f12c7cecdff20589e8329acef30523114292a2834392b53f5d31c40132bc4232 SHA512 bd8ea74c281d64262d499970c0861659679670f052acde37f1d7fa50f2184c816e5681ef2566bf3a6010d150f9c649b39024a79a269e2a7b47057e1d8173d2ce
diff --git a/dev-ruby/pry/pry-0.12.0.ebuild b/dev-ruby/pry/pry-0.12.0.ebuild
new file mode 100644
index 000000000000..dca7baa3cb19
--- /dev/null
+++ b/dev-ruby/pry/pry-0.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_GEMSPEC=${PN}.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pry is a powerful alternative to the standard IRB shell for Ruby"
+HOMEPAGE="https://github.com/pry/pry/wiki"
+SRC_URI="https://github.com/pry/pry/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="ruby19"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+ruby_add_rdepend "
+ >=dev-ruby/coderay-1.1.0 =dev-ruby/coderay-1.1*
+ >=dev-ruby/method_source-0.9.0 =dev-ruby/method_source-0.9*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/open4-1.3
+ >=dev-ruby/rake-0.9
+ >=dev-ruby/mocha-1.0
+ )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on git.
+ # Loosen coderay dependency.
+ sed -e '/git ls-files/d' \
+ -e '/coderay/s/~>/>=/' \
+ -e '/bundler/d' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/[Bb]undler/d' -e "1irequire 'mocha/api'\ " -i spec/helper.rb || die
+ # Out of date tests
+ rm spec/commands/gist_spec.rb || die
+}