summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pusher-client')
-rw-r--r--dev-ruby/pusher-client/pusher-client-0.6.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/pusher-client/pusher-client-0.6.2-r1.ebuild b/dev-ruby/pusher-client/pusher-client-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..622335344978
--- /dev/null
+++ b/dev-ruby/pusher-client/pusher-client-0.6.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Client for consuming WebSockets from http://pusher.com"
+HOMEPAGE="https://github.com/pusher-community/pusher-websocket-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/websocket-1:0
+ dev-ruby/json:*
+"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}